天天看点

HDOJ1233-----最小生成树简单题

Problem Description 某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input 测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。

当N为0时,输入结束,该用例不被处理。

Output 对每个测试用例,在1行里输出最小的公路总长度。

Sample Input

3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
        

Sample Output

3
5
       
#include<cstdio>  
#include<algorithm>  
using namespace std;   
int father[102];  
struct node{  
    int a, b, value;  
}w[5002];  
bool cmp(const node &a,const node &b){  
    return a.value < b.value;  
}  
int find(int x){  
    return father[x] == x ? x : (father[x] = find(father[x]));//压缩路径
}  
void merge(int x, int y, int z, int *tp){  
    int a = find(x), b = find(y);  
    if(a != b){  
        (*tp) += z;  
        father[a] = b;  
    }  
}  
int main()  
{  
    int n, m, sum;  
    while(scanf("%d", &n) && n)  
    {  
        sum = 0;  
        m = n * (n-1) / 2;  
        for(int i = 1; i <= m; i++){
        	scanf("%d%d%d",&w[i].a, &w[i].b, &w[i].value);
		}  
        sort(w+1, w+m+1, cmp);//按边长从小到大排序  
        for(int i = 1; i <= n; i++){
        	father[i] = i;
		}  
        for (int i = 1; i <= m; i++)  {  
            merge(w[i].a, w[i].b, w[i].value, &sum);  
        }  
        printf("%d\n",sum);  
    }  
}