天天看点

HDU 1062 Text Reverse Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16342    Accepted Submission(s): 6205

Problem Description Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca
        

Sample Output

hello world!
I'm from hdu.
I like acm.


   
    
     Hint
    
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

   
    
        
#include<stdio.h>
#include<string.h>
char a[1010],ch[1000];
int main()
{
	int t,i,j;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		gets(a);
		i=0;
		while(a[i])
		{
			j=0;
			while(a[i]!=' '&&a[i]!='\0')
			{
				ch[j]=a[i];
				j++;
				i++;
			}
			ch[j]='\0';
			strrev(ch);<span style="white-space:pre">		</span>//注意此函数的运用,是将字符串逆序输出
			printf("%s",ch);
			if(a[i]==' ')
			{
				printf(" ");
				i++; 
			}
		}
		printf("\n");
	}
	return 0;
}
           

继续阅读