天天看点

HDU1008-Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43181    Accepted Submission(s): 23706

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2

3 2 3 1

Sample Output

17

41

Author

ZHENG, Jianqiang

Source

ZJCPC2004

开始攻克数学题!先从简单的开始吧

简单数学题,也可以说是一个简单模拟把

没有任何算法,直接模拟即可

AC代码:

#include<stdio.h>
#include<string.h>
int a[110];
int main()
{
   int i,j,n,m,sum;
   while(scanf("%d",&n),n!=0)
   {
      memset(a,0,sizeof(a));
      for(i=0;i<n;i++)
      scanf("%d",&a[i]);
      
      m=0;sum=0;
      for(i=0;i<n;i++)
      {
         if(a[i]>m)
         {
            sum+=(a[i]-m)*6+5;
            m=a[i];
         }
         else
         {
            if(a[i]==m)
            {
               sum+=5;//注意 1->1也要停留5秒......蛋疼 
            }
            else
            {
                sum+=(m-a[i])*4+5;
                m=a[i];
            }
         }
      }
      printf("%d\n",sum);
   }
   return 0;   
}