天天看点

杭电ACM 1004 Let the Balloon Rise Let the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 118927    Accepted Submission(s): 46618

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
        

Sample Output

red
pink
        

Author WU, Jiazhi  

Source ZJCPC2004  

Recommend JGShining   |   We have carefully selected several similar problems for you:   1002  1001  1008  1005  1009   

#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
int main(void)
{
	int n, i, j;
	cin >> n;
	while (n)
	{
		int Max = -1000000;
		int maxc = 0;
		string *color = new string[n];
		int * sum = new int[n];
		int * visited = new int[n]; //增加一个监视数组,防止重复计数
		memset(sum, 0, n*sizeof(int));
		memset(visited, 0, n*sizeof(int));
		for (int i = 0; i < n; i++)
		{
			cin >> color[i];
		}
		for (i = 0; i < n; i++)
		{
			if (visited[i] == 1)//已经记录过就跳过本次
				continue;
			else
			{
				visited[i] = 1;//进行记录,先赋值为1
				sum[i]++;//初始化值为1,因为进行到这一步就意味着已经有一个这样的颜色了
				for (j = i + 1; j < n; j++)
					if (visited[j] == 0 && !(color[i].compare(color[j]))) //.compare操作相同返回0,!0=1,并且还要保证没有被浏览过
					{
						sum[i]++;
						visited[j] = 1;//标记此颜色已被记录过
					}
			}
		}
		for (int k = 0; k < n; k++)
			if (sum[k] > Max) {
				Max = sum[k];
				maxc = k;
			}//记录最大值的坐标
		cout <<color[maxc] << endl;  //将坐标直接带入到string color的坐标中(因为sum和color的坐标是相对的)
		cin >> n;
	}
}
           

简单的遍历,处理好一些小细节就可以