天天看点

HDU 5984 ACM-ICPC Regional QingDao(数学期望)

Pocky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 580    Accepted Submission(s): 315

Problem Description

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.

While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.

Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input

6

1.0 1.0

2.0 1.0

4.0 1.0

8.0 1.0

16.0 1.0

7.00 3.00

Sample Output

0.000000

1.693147

2.386294

3.079442

3.772589

1.847298

Source

​​2016ACM/ICPC亚洲区青岛站-重现赛(感谢中国石油大学) ​​

        人生第一道数学期望程序,纪念一下……

        就是跟你一根棍子长度为L,你每次可以在任何一个点把它折断,同时拿走左边那段,对右边那段棍子继续重复刚刚的动作,知道剩下的棍子的长度小于d。然后问你在根除L和d的情况下,期望多少次能够使得不能继续把棍子截断。

        本来好好的一道数学题,被大部分人做成了找规律的玄学题……鄙视(╬▔皿▔)凸找规律的人……

#include<bits/stdc++.h>
#define N 100000000000
#define C 0.5772156649              //欧拉常数
using namespace std;

double l,d,f,s;

double getsum(long long x)            //计算调和级数的和
{
  return log(x)+C;
}

int main()
{
  int T_T;
  cin>>T_T;
  while(T_T--)
  {
    int i; f=s=0;
    scanf("%lf%lf",&l,&d);
    if (l<=d) 
    {
      printf("%.6lf\n",0);
      continue;
    }
    double blocks=l/N;          //计算单位长度
    printf("%.6lf\n",getsum(N)-getsum(d/blocks)+1);    //结果减去长度为d时对应项的和再加上1
  }
  return 0;
}