天天看点

1002. A+B for Polynomials (25)1002. A+B for Polynomials (25)

1002. A+B for Polynomials (25)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B 判题程序 Standard 作者 CHEN, Yue This time, you are supposed to find A+B where A and B are two polynomials. Input Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000. Output For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place. Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
      
Sample Output
3 2 1.5 1 2.9 0 3.2      
这里我们利用的是map的思维,将多项式的次数与系数对应起来,然后按系数进行运算
#include<iostream>
#include<string.h>
#include<string>
#include<stdio.h>

using namespace std;

int main() {
  double poly[1020];
  for(int i=0;i<1020; i++)
       {
             poly[i]=0;
       }
  int s1, s2;
  int a;
  double b;
  cin>>s1;
  for (int i = 1; i <= s1; i++) {
    cin>>a>>b;
    poly[a] += b;
  }
  cin>>s2;
  for (int j = 1; j <= s2; j++) {
    cin>>a>>b;
    poly[a] += b;
  }
  int num = 0;
  for (int i = 0;i<1020;i++) {
              if (poly[i] !=0) {
                  num++;
             }
  }
  cout<<num;
       for (int i = 1019; i >=0; i--) {
            if (poly[i] != 0.0) {
                printf(" %d %.1lf", i, poly[i]);
            }
      }
      cout<<endl;
      return 0;
}
           
PAT