天天看点

HDU - 1532Drainage Ditches

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20331    Accepted Submission(s): 9749

Problem Description Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output For each case, output a single integer, the maximum rate at which water may emptied from the pond. 

Sample Input

5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10  

Sample Output

50  

Source USACO 93  

Recommend lwg N条边,M个节点,接着 N行

每行三个数字u,v,w,代表u到v容量为w,求汇点(M点)流入的总流量

题解:标号法简单,可惜  我没看过标号法并不知道,只是用了Edmond Karp算法

及 反复寻找源点s到汇点t之间的增广路径,若有,找出增广路径上每一段[容量-流量]的最小值delta,若无,则结束。  

在寻找增广路径(若P是图G中一条连通两个未匹配顶点的路径,并且属于M的边和不属于M的边(即已匹配和待匹配的边)在P上交替出现,则称P为相对于M的一条增广路径    即s是否能到达t,,例1到2,2到3,则1到3就是一条增广路径)时,

可以用BFS来找,并且更新残留网络的值(涉及到反向边)。

而找到delta后,则使最大流值加上delta,更新为当前的最大流值。

针对这个题http://www.wutianqi.com/?p=3107

#include <iostream>  
#include <queue>  
#include <algorithm>  
using namespace std;  
const int msize = 205;  
  
int N, M; // N–路径数, M–结点数  
int r[msize][msize]; //  
int pre[msize]; // 记录结点i的前向结点为pre[i]  
bool vis[msize]; // 记录结点i是否已访问  
  
// 用BFS来判断从结点s到t的路径上是否还有delta  
// 即判断s,t之间是否还有增广路径,若有,返回1  
bool BFS(int s, int t)  
{  
    queue<int> que;  
    memset(pre, -1, sizeof(pre));  
    memset(vis, false, sizeof(vis));  
  
    pre[s] = s;  
    vis[s] = true;  
    que.push(s);  
  
    int p;  
    while(!que.empty())  
    {  
        p = que.front();  
        que.pop();  
        for(int i=1; i<=M; ++i)  
        {  
            if(r[p][i]>0 && !vis[i])  
            {  
                pre[i] = p;  
                vis[i] = true;  
                if(i == t) // 存在增广路径  
                    return true;  
                que.push(i);  
            }  
        }  
    }  
    return false;  
}  
int EK(int s, int t)  
{  
    int maxflow = 0, d;  
    while(BFS(s, t))  
    {  
        d= INT_MAX;  
        // 若有增广路径,则找出最小的delta  
        for(int i=t; i!=s; i=pre[i])  
            d = min(d, r[pre[i]][i]);  
        // 这里是反向边,看讲解  
        for(int i=t; i!=s; i=pre[i])  
        {  
            r[pre[i]][i] -= d;  
            r[i][pre[i]] += d;  
        }  
        maxflow += d;  
    }  
    return maxflow;  
}  
  
int main()  
{  
    while(cin >> N >> M)  
    {  
        memset(r, 0, sizeof(r));  
        int s, e, c;  
        for(int i=0; i<N; ++i)  
        {  
            cin >> s >> e >> c;  
            r[s][e] += c; // 有重边时则加上c  
        }  
  
        cout << EK(1, M) << endl;  
    }  
    return 0;  
}  
           
http://www.wutianqi.com/?p=3107
           

针对这个方法https://www.cnblogs.com/ShaneZhang/p/3755479.html

继续阅读