天天看点

HDU 2579 Dating with girls(2) (BFS) Dating with girls(2)

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2416    Accepted Submission(s): 690

Problem Description If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity! 

The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there. 

There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.

HDU 2579 Dating with girls(2) (BFS) Dating with girls(2)

Input The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).

The next r line is the map’s description.  

Output For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".  

Sample Input

1
6 6 2
...Y..
...#..
.#....
...#..
...#..
..#G#.
        

Sample Output

7
  
  
   
        
HDU 2579 Dating with girls(2) (BFS) Dating with girls(2)
直接取模判断
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
typedef long long LL;
const int MAXN = 100 + 5;
char Fig[MAXN][MAXN];
bool vis[MAXN][MAXN][15];
int dx[] = {1,0,-1,0};
int dy[] = {0,1,0,-1};
int r, c, k;

int MinTime;

struct point {
    int x, y, time;
    point(int x,int y, int time):x(x), y(y), time(time) {}
};

void BFS(int x,int y) {
    queue<point>que;
    que.push(point(x, y, 0));
    while(! que.empty()) {
        point e = que.front();
        que.pop();
        if(vis[e.x][e.y][e.time % k] || e.x < 0 || e.y < 0 || e.x >= r || e.y >= c) continue;
        if(Fig[e.x][e.y] == '#') {
            if(e.time % k != 0) continue;
        }
        vis[e.x][e.y][e.time % k] = true;
        if(Fig[e.x][e.y] == 'G') {
            MinTime = e.time;
            return;
        }
        for(int i = 0; i < 4; i ++) {
            int nx = e.x + dx[i];
            int ny = e.y + dy[i];
            que.push(point(nx, ny, e.time + 1));
        }
    }
}

void solve(int x,int y) {
    memset(vis, false,sizeof(vis));
    MinTime = -1;
    BFS(x, y);
    if(MinTime == -1) {
        printf("Please give me another chance!\n");
    } else {
        printf("%d\n",MinTime);
    }
}
int main() {
    int T,ix,iy;
    scanf("%d", &T);
    while(T --) {
        scanf("%d%d%d", &r, &c, &k);
        for(int i = 0; i < r; i ++) {
            scanf("%s", Fig[i]);
            for(int j = 0; j < c; j ++) {
                if(Fig[i][j] == 'Y') {
                    ix = i;
                    iy = j;
                }
            }
        }
        solve(ix,iy);
    }
}