天天看点

PAT Advanced 1029 Median (25 )

PAT Advanced 1029 Median (25 )

    • 题目描述
    • Input Specification:
    • Output Specification:
    • Sample Input:
    • Sample Output:
    • 解题思路
    • Code

题目描述

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2× 10 ​ 5 10​^5 10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17
           

Sample Output:

13
           

解题思路

这题严重卡空间,两个数组是不能都存下来的,

long int

int

是4个字节,输入的一个数组的长度N (≤2× 10 ​ 5 10​^5 10​5​​) ,所以整个数组存在来的空间是8x 1 0 5 10^5 105B,存两个就超过内存限制的1.5MB空间了。但是第一个数组可以用队列存下来,然后对第二个数组在线操作,进第二个队列后,比较两个队列的首元素,把更小的出列,直到第(n1+n2+1)/2个元素。要注意读完第二个数组仍然可能没有找到,因此还要继续寻找。其中有个技巧就是读完一个队列后在其最后面加上

int

的最大值

0x7fffffff

,避免对空队列操作。

Code

  • AC代码
#include<bits/stdc++.h>
using namespace std;
const int INF = 0x7fffffff;
void pop(queue<int> &q1, queue<int> &q2, int &cnt) {
	q1.front() <= q2.front() ? q1.pop() : q2.pop();
	cnt++;
}
int main() {
	//freopen("in.txt", "r", stdin);
	ios::sync_with_stdio(false);
	int n1, n2, cnt = 0, temp;
	cin >> n1;
	queue<int> q1, q2;
	for(int i = 0; i<n1; i++) {
		cin >> temp;
		q1.push(temp);
	}
	q1.push(INF);
	cin >> n2;
	int mid = (n1+n2-1)/2;
	for(int i = 0; i<n2; i++) {
		cin >> temp;
		q2.push(temp);
		if(cnt == mid) {
			cout << min(q1.front(), q2.front());
			return 0;
		}
		pop(q1, q2, cnt);
	}
	q2.push(INF);
	while(cnt != mid) {
		pop(q1, q2, cnt);
	}
	cout << min(q1.front(), q2.front());
	return 0;
}