天天看点

HDU 5625 Clarke and chemistry 模拟Clarke and chemistry

Clarke and chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 145    Accepted Submission(s): 75

Problem Description Clarke is a patient with multiple personality disorder. One day, Clarke turned into a junior student and took a chemistry exam.

But he did not get full score in this exam. He checked his test paper and found a naive mistake, he was wrong with a simple chemical equation balancer.

He was unhappy and wanted to make a program to solve problems like this.

This chemical equation balancer follow the rules:

Two valences A combined by |A| elements and B combined by |B| elements.

We get a new valence C by a combination reaction and the stoichiometric coefficient of C is 1 . Please calculate the stoichiometric coefficient a of A and b of B that aA+bB=C,  a,b∈N∗ .  

Input The first line contains an integer T(1≤T≤10) , the number of test cases.

For each test case, the first line contains three integers A,B,C(1≤A,B,C≤26) , denotes |A|,|B|,|C| respectively.

Then A+B+C lines follow, each line looks like X c , denotes the number of element X of A,B,C respectively is c . ( X is one of 26 capital letters, guarantee X of one valence only appear one time, 1≤c≤100 )  

Output For each test case, if we can balance the equation, print a and b . If there are multiple answers, print the smallest one, a is smallest then b is smallest. Otherwise print NO.  

Sample Input

2
2 3 5	
A 2
B 2
C 3
D 3
E 3
A 4
B 4
C 9
D 9
E 9
2 2 2
A 4
B 4
A 3
B 3
A 9
B 9
        

Sample Output

2 3
NO

Hint:
The first test case, $a=2, b=3$ can make equation right.  
The second test case, no any answer.
        

题意:物质A和物质B生成物质C,暴力求解进行模拟即可

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll long long
#define N 105
int A[N], B[N], C[N];

int main()
{
// freopen("E:\input.txt", "r", stdin);
    int i, j, n;
    int t;
    int a, b, c;
    char s[5];
    int num;           //开始将num定义成了char类型,导致s一直读不进去
    scanf("%d", &t);
    while (t--)
    {
        memset(A, 0, sizeof(A));
        memset(B, 0, sizeof(B));
        memset(C, 0, sizeof(C));
        scanf("%d %d %d", &a, &b, &c);

        for (i = 0; i < a; i++)
        {
           //字符数组s读不进去
           scanf("%s %d", s, &num);
           //cin >> s >> num;
           A[s[0] - 'A'] = num;
        }
        for (i = 0; i < b; i++)
        {
            scanf("%s %d", s, &num);
            B[s[0] - 'A'] = num;
        }
        for (i = 0; i < c; i++)
        {
            scanf("%s %d", s, &num);
            C[s[0] - 'A'] = num;
        }
        int a1, b1;
        bool flag = true;
        for (a1 = 1; a1 < N; a1++)
        {
            for (b1 = 1; b1 < N; b1++)
            {
                flag = true;
                for (i = 0; i < 26 && flag; i++)
                {
                    if (A[i] * a1 + B[i] * b1 != C[i])
                    {
                        flag = false;
                    }
                }
                if (flag)
                {
                    break;
                }
            }
            if (flag)
            {
                break;
            }
        }
        if (flag)
        {
            printf("%d %d\n", a1, b1);
        }
        else
        {
            printf("NO\n");
        }
    }
    return 0;
}