天天看点

hdu 1312 DFS深度搜索典型例题

题目链接

Problem Description There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
        

Sample Output

45
59
6
13
        
#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
#define N 25
char a[N][N];
int n, m;
int num;
int f[4][2] = {{-1, 0}, {1, 0}, {0, 1}, {0, -1}};

void fun(int x, int y)
{
    num++;
    a[x][y] = '#';
    int p, q;
    for (int i = 0; i < 4; i++)
    {
        p = x + f[i][0];
        q = y + f[i][1];
        if (p > 0 && q > 0 && p <= n && q <= m && a[p][q] == '.')
        {
            fun(p, q);
        }
    }
}


int main()
{
  //freopen("E:\input.txt", "r", stdin);
    int i, j;


    while ((scanf("%d%d", &m, &n)) != EOF)
    {
       getchar();
       if (n == 0 && m == 0)
       {
           break;
       }
       memset(a, 0, sizeof(a));
       int n1, m1;
       for (i = 1; i <= n; i++)
       {
           for (j = 1; j <= m; j++)
           {
               scanf("%c", &a[i][j]);
               if (a[i][j] == '@')
               {
                   n1 = i;
                   m1 = j;
               }
           }
           getchar();
       }
       num = 0;
       fun(n1, m1);
       printf("%d\n", num);
    }
    return 0;
}