天天看点

PAT 甲级 1078  Hashing

1078 Hashing (25 point(s))

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSizeis the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

Sample Input:

4 4
10 6 4 15      

Sample Output:

0 1 4 -      

经验总结:

AC代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
const int maxn=10010;
int prime[maxn],pnum=0;
bool flag[maxn]={false},hashtable[maxn]={false};
void find_prime()
{
  flag[0]=flag[1]=true;
  for(int i=2;i<maxn;++i)
    if(flag[i]==false)
    {
      prime[pnum++]=i;
      for(int j=i+i;j<maxn;j+=i)
        flag[j]=true;
    }
}
int main()
{
  int n,m,t;
  find_prime();
  scanf("%d%d",&m,&n);
  if(flag[m]==true)
  {
    int *p=upper_bound(prime,prime+pnum,m);
    m=prime[p-prime];
  }
  for(int i=0;i<n;++i)
  {
    scanf("%d",&t);
    int address=t%m;
    if(hashtable[address]==false)
    {
      hashtable[address]=true;
      printf("%d",address);
    }
    else
    {
      int tpos,f=0;
      for(int j=1;j<=m;++j)
      {
        tpos=(address+j*j)%m;
        if(hashtable[tpos]==false)
        {
          hashtable[tpos]=true;
          printf("%d",tpos);
          f=1;
          break;
        }
      }
      if(f==0)
        printf("-");
    }
    printf("%c",i<n-1?' ':'\n');
  }
  return 0;
}