天天看点

POJ1651 Multiplication Puzzle 区间DP

Multiplication Puzzle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8258 Accepted: 5127

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring

10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be

1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5
      

Sample Output

3650      
/**************************
功能:在区间中任取三个数做乘积后去除中间的数字,将所有乘积相加直至剩余两个数,
求该乘积和的最小值
输入数据:n个数,范围0-INF,maxn个
输出数据:最小的乘积和
递推公式:dp[i][j]=dp[i][k]+dp[k][j]+data[i]*data[k]*dp[j],表示从i到
j这个区间的最小乘积和,k表示最后一次取的数,且端点值不能取
**************************/

#include <iostream>
#include <stdio.h>
#include <string.h>
#define maxn 110
#define INF 100000000
using namespace std;


int dp[maxn][maxn];
int data[maxn];

void init(int n)
{
    for(int i=0;i<=n-3;i++)
        dp[i][i+2]=data[i]*data[i+1]*data[i+2];
}

int solve(int n)
{
    int len,i,j,k,tmp;
    for(len=4;len<=n;len++)//区间长度
    {
        for(i=0;i<=n-len;i++)//区间端点值
        {
            j=i+len-1;
            dp[i][j]=INF;
            for(k=i+1;k<j;k++)//最后取到的数
            {
                tmp=dp[i][k]+dp[k][j]+data[i]*data[k]*data[j];
                if(tmp<dp[i][j])
                    dp[i][j]=tmp;
            }
        }
    }
    return dp[0][n-1];

}

int main()
{
    int n,i,ans;
    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++)
            scanf("%d",&data[i]);
        init(n);
        ans=solve(n);
        printf("%d\n",ans);
    }
    return 0;
}
/********************************
输入:
6
10 1 50 50 20 5
输出:
3650
********************************/