天天看点

POJ 1458 Common Subsequence(最长公共子序列LCS)

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x  ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp      

Sample Output

4
2
0      

就是求最长公共子序列,题意没啥好讲的,子序列和最长子序列是啥就不说了。

用一个二维数组dp[i][j]来表示到a串第i-1个和b串第j-1个字符的最长子序列长度,如果a[i] b[i]相等,说明必定在最长子序列里,子序列长度++,如果不相等的话说明最长子序列长度在这个状态不变,从前面两个邻近状态挑大的那个。

dp问题要从邻近的两个值里挑最大的,这就是dp的意义嘛,找出邻近问题的最优解。

AC代码:

#include <iostream>
#include <string>
#include <cstring>
using namespace std;
int dp[1010][1010];
int main()
{
    string a,b;

    while(cin>>a>>b)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=a.size();i++)
        {
            for(int j=1;j<=b.size();j++)
            {
                if(a[i-1]==b[j-1]) dp[i][j]=dp[i-1][j-1]+1;
                else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        cout<<dp[a.size()][b.size()]<<endl;
    }
    return 0;
}
           

还有个问题,就是如何按照字典序输出最长子序列,这个就留待以后解决了。