天天看点

数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,de,g,f, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Sample Input

abc,de,g,f,

Sample Output

3

Hint

Source

xam

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *r,*l;
};
char a[55];
int i;
int len;
struct node *creat()//递归建立二叉树//
{
    char c;
    struct node *root;
    c=a[i++];
    if(c==',')
        return NULL;
    else
    {
        root=(struct node *)malloc(sizeof(struct node));
        root->data=c;
        root->l=creat();
        root->r=creat();
    }
    return root;
};
void shu(struct node *root)
{
    if(root)
    {
        if(root->l)
            shu(root->l);
        if(root->r)
            shu(root->r);//递归左右子树//
        if(root->l==NULL&&root->r==NULL)
            len++;//找到一个左右子树为空的节点就加一//
    }
    return;//函数递归终止条件//

}
int main()
{
    struct node *root;
    while(scanf("%s",a)!=EOF)
    {
        i=0;
        len=0;
        root=(struct node *)malloc(sizeof(struct node));
        root=creat();
        shu(root);
        printf("%d\n",len);
    }
    return 0;
}
           

继续阅读