天天看点

PAT甲级——A1016 Phone Bills

题目

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-linerecord. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers’ names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line
           

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80
           

Solution:

题意:

就是求一个电话煲的话费单,记得电话的接与挂要匹配上

然后就是注意时间处理了,处理不好就巨麻烦

Code

#include <iostream>
#include <vector>
#include <map>
#include <string>
using namespace std;
int N;
vector<int>cost(25);

double calMoney(string str, int& time)
{
    int d, h, m;
    double money = 0;
    d = (str[3] - '0') * 10 + str[4] - '0';
    h = (str[6] - '0') * 10 + str[7] - '0';
    m = (str[9] - '0') * 10 + str[10] - '0';
    money += cost[24] * 60 * d + cost[h] * m;
    for (int i = 0; i < h; ++i)
        money += cost[i] * 60;
    time = 24 * 60 * d + h * 60 + m;
    return money;
}
int main()
{    
    for (int i = 0; i < 24; ++i)
    {
        cin >> cost[i];
        cost[24] += cost[i];
    }
    cin >> N;
    map<string, map<string, string>,less<string>>data;
    //外部用名字排序,名字是用降序排序,内部用时间排序,时间时用默认升序排序
    for (int i = 0; i < N; ++i)
    {
        string name, time, type;
        cin >> name >> time >> type;
        data[name][time] = type;
    }
    for (auto ptr = data.begin(); ptr != data.end(); ++ptr)
    {
        int f = 1, st = 0, et = 0;
        double s = 0, sum = 0;
        string sl,el;
        for (auto it = ptr->second.begin(); it != ptr->second.end(); ++it)
        {
            if (it == ptr->second.begin())    continue;
            auto pt = it;
            if (it->second == "off-line" && (--pt)->second == "on-line")
            {
                if (f==1)
                {
                    cout << ptr->first << " " << it->first[0] << it->first[1] << endl;
                    f = 0;
                }
                s = calMoney(it->first, et) - calMoney(pt->first, st);
                sl.assign(pt->first.begin() + 3, pt->first.end());
                el.assign(it->first.begin() + 3, it->first.end());
                cout << sl << " " << el << " " << (et - st) << " ";
                printf("$%0.2f\n", s/100);
                sum += s;
            }
        }
        if(f==0)
            printf("Total amount: $%0.2f\n", sum/100);
    }
    return 0;
}