天天看点

运算符重载——电子时钟中的运算符重载

题目描述

通过本题目的练习可以运算符重载的方法; 设计一个时间类Time,私有数据成员有hour(时)、minute(分)、second(秒); 公有成员函数有:setHour(int)设置数据成员hour的值,非法的输入默认为12;setMinue(int)设置数据成员minute的值,非法输入默认为0;setSecond(int)设置数据成员second的值,非法输入默认为0;setTime(int,int,int)设置时、分、秒三个数据成员的值;三个成员函数int getHour(); int getMinute(); int getSecond();分别用于获取时间对象的属性值。 定义两个构造函数Time(); 和 Time(int,int,int); 定义一个成员函数void displayTime(); 用于显示时间,注意格式为 hh:mm:ss,位数不够用0填充; 定义一个时钟增加1的成员函数 void tick(); 把second的值加1,并注意是否到60; 定义一个成员或友元函数 bool operator= =(….); 判断两个时间对象的值是否相等; 定义一个成员或友元函数bool operator>(…..); 判断第一个时间对象的值是否大于第二个时间对象的值。     在主函数main()中指定开始时间和结束时间,并调用相应成员函数,显示从开始时间到结束时间之间所有时间对象的值,其格式见示例输出。

输入

输入6个整数,之间用一个空格间隔;分别表示开始时间的时、分、秒和结束时间的时、分、秒的值

输出

从开始时间到结束时间之间所有时间对象的值;每个值占一行,格式为hh:mm:ss

示例输入

01 01 01 01 01 10      

示例输出

01:01:01
01:01:02
01:01:03
01:01:04
01:01:05
01:01:06
01:01:07
01:01:08
01:01:09
01:01:10      

提示

输入 11 10 12 10 12 56 输出 The begin time is not earlier than the end time!  

#include <iostream>
#include <iomanip>
using namespace std;
class Time
{
	public:
		Time(){hour=0;minute=0;sec=0;}
		Time(int h,int m,int s);
		void displayTime();
		void tick();
		friend bool operator ==(Time &t1,Time &t2);
		friend bool operator >(Time &t1,Time &t2);
	private:
		int hour;
		int minute;
		int sec;
};
Time::Time(int h,int m,int s)
{
    hour=h>12?12:h;
    minute=m>59?0:m;
    sec=s>59?0:s;
}
void Time::displayTime()
{
	cout <<setw(2) <<setfill('0') <<hour <<":" <<setw(2) <<setfill('0') <<minute <<":" <<setw(2) <<setfill('0') <<sec <<endl;
}
void Time::tick()
{
	if(++sec>=60)
	{
		sec-=60;
		++minute;
	}
	if(minute>=60)
	{
		minute-=60;
		++hour;
	}
}
bool operator ==(Time &t1,Time &t2)
{
	if(t1.hour==t2.hour && t1.minute==t2.minute && t1.sec==t2.sec)
		return true;
	else
		return false;
}
bool operator >(Time &t1,Time &t2)
{
	if((t1.hour>t2.hour) || (t1.hour==t2.hour && t1.minute>t2.minute) || (t1.hour==t2.hour && t1.minute==t2.minute && t1.sec>t2.sec))
		return true;
	else
		return false;
}
int main()
{
	int hour1,hour2,minute1,minute2,sec1,sec2;
	cin >>hour1 >>minute1 >>sec1 >>hour2 >>minute2 >>sec2;
	Time t1(hour1,minute1,sec1),t2(hour2,minute2,sec2);
	if(operator ==(t1,t2))
		t1.displayTime();
	else if(operator >(t1,t2))
		cout <<"The begin time is not earlier than the end time!" <<endl;
	else
	{
		while(!(operator >(t1,t2)))
		{
			t1.displayTime();
			t1.tick();
		}
	}
	return 0;
}
           

继续阅读