天天看点

PAT 1003. Emergency (25) 【精华】 1003. Emergency (25)

1003. Emergency (25)

时间限制 400 ms

内存限制 32000 kB

代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
      

Sample Output

2 4
      

提交代码

/*
解题思想:
先用dijkstra算法求出源点到各点的最短路径
然后进行dfs深搜,若等于最短路径,则计数加一,并更新最大救援数
*/
#include<stdio.h>
const int MAX=501,INF=1000000;
int team[MAX],mark[MAX],dist[MAX]; //各城市的人数;是否被标记 ;从源点到各点的距离 
int road[MAX][MAX];		          //城市间的距离 
int ans,maxTeam;

void dij(int n,int source)
{
    int i,j,minDis,nowP;
 	for(i=0;i<n;i++)
        dist[i]=road[source][i];
    mark[source]=1;
    for(i=0;i<n-1;i++){          //n-1轮扫描标记,i只是起轮数作用 ;修改源点到所有结点的距离,
	    minDis=INF;  nowP=0;
	    for(j=0;j<n;j++){       //每次扫描 全部结点 选最短路径加入集合中 
			if(!mark[j]&&dist[j]<minDis){
	             minDis=dist[j];
				 nowP=j;
			}
		}
		mark[nowP]=1;
		for(j=0;j<n;j++){       //修改最短路径
		     if(!mark[j]&&road[nowP][j]<INF&&dist[nowP]+road[nowP][j]<dist[j])	
			 	  dist[j]=dist[nowP]+road[nowP][j];
	    } 				 
    }                
}
void dfs(int n,int tmpP,int dest,int sumDist,int sumTeam) //变的是tmpP,随之而变得是sumDist和sumTeam 
{
 	 int i;
	 if(tmpP==dest){             //递归出口1
		if(sumDist==dist[dest]){
		     ans++;
		     if(sumTeam>maxTeam)
		         maxTeam=sumTeam;
		}
		return;				   
    }
    if(sumDist>dist[dest])     //递归出口2
         return;
    for(i=0;i<n;i++){          //递归遍历 
         if(!mark[i]&&road[tmpP][i]<INF){  //未被标记 且 有路径 
	          mark[i]=1;
              dfs(n,i,dest,sumDist+road[tmpP][i],sumTeam+team[i]);
              mark[i]=0;
		  }
	}	   	 
}

int main()
{
 	int n,m,source,dest  ,c1,c2,k;
 	int i,j;
	//freopen("G:\\in.txt","r",stdin);
 	while(scanf("%d%d%d%d",&n,&m,&source,&dest)!=EOF){									   
 //-----------------------初始化--------------- 
  	    for(i=0;i<n;i++){
		    team[i]=0;
			mark[i]=0;
		    dist[i]=INF;		    
		    for(j=0;j<n;j++)
  				road[i][j]=INF;
		    road[i][i]=0;
		}
//		printf("%d--%d--%d--%d--%d--%d--%d",team[0],team[3],dist[0],dist[3],dist[1],road[3][3],road[2][3]);
///----------------------------------------------- 
	    for(i=0;i<n;i++)
		    scanf("%d",&team[i]);
		for(i=0;i<m;i++){
			scanf("%d%d%d",&c1,&c2,&k);
			road[c1][c2]=road[c2][c1]=k;
		}
		dij(n,source);
		for(i=0;i<n;i++)//!!!dij()执行完后造成部分元素已被标记,此处要重新初始化 
		     mark[i]=0;
	    mark[source]=1;
        dfs(n,source,dest,0,team[source]);
        printf("%d %d\n",ans,maxTeam);
    } 	
	getchar();
 	return 0; 	
}