天天看点

POJ 1088 滑雪【经典DP】

滑雪

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 96358 Accepted: 36539

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 

1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9      

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
      

Sample Output

25      

Source

SHTSC 2002

原题链接:http://poj.org/problem?id=1088

dp[x][y]表示从(x,y)为起点的最长滑雪距离.

AC代码:

/**
  * 行有余力,则来刷题!
  * 博客链接:http://blog.csdn.net/hurmishine
  *
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=100+5;
int a[maxn][maxn];
int dp[maxn][maxn];
int n,m;
int dir[4][2]={1,0,0,1,-1,0,0,-1};
int DP(int x,int y)
{

    if(dp[x][y])
        return dp[x][y];
    int ans=0;
    for(int i=0;i<4;i++)
    {
        int xx=x+dir[i][0];
        int yy=y+dir[i][1];
        if(xx<0||xx>=n||yy<0||yy>=m)
            continue;
        if(a[xx][yy]<a[x][y])
            ans=max(ans,DP(xx,yy));
    }
    dp[x][y]=ans+1;
    return dp[x][y];
}
int main()
{
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                cin>>a[i][j];
        }
        memset(dp,0,sizeof(dp));
        int maxx=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                maxx=max(maxx,DP(i,j));
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}
           

参考博客:

http://blog.csdn.net/zs120197/article/details/52493658

http://blog.csdn.net/morgan_xww/article/details/5777224