天天看点

PAT B1049/A1104 题解

1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10

​5

​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4

0.1 0.2 0.3 0.4

Sample Output:

5.00

题目大意:题目的意思是给定一个片段,然后找出连续的各个片段,求出其和就可以了。

题目思路:时间限制为200ms,如果是直接进行循环来求和的话,会非常的麻烦。这个思路也没有怎么想过,因为它的tag就是简单数学,所以通过优化算法来降低时间复杂度的话。因此只需要找出片段每一项的次数规律就可以了。

#include<cstdio>
#include<iostream>
using namespace std;
const int maxn=100010;
double num[maxn];
int main(){
	int n;
	cin>>n;
	double sum=0;
	for(int i=1;i<=n;i++){
		scanf("%lf",&num[i]);
		sum+=num[i]*(n+1-i)*i;
	}
	printf("%.2f",sum);
	return 0;
}
           

继续阅读