天天看點

PAT B1049/A1104 題解

1104 Sum of Number Segments (20 分)

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10

​5

​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4

0.1 0.2 0.3 0.4

Sample Output:

5.00

題目大意:題目的意思是給定一個片段,然後找出連續的各個片段,求出其和就可以了。

題目思路:時間限制為200ms,如果是直接進行循環來求和的話,會非常的麻煩。這個思路也沒有怎麼想過,因為它的tag就是簡單數學,是以通過優化算法來降低時間複雜度的話。是以隻需要找出片段每一項的次數規律就可以了。

#include<cstdio>
#include<iostream>
using namespace std;
const int maxn=100010;
double num[maxn];
int main(){
	int n;
	cin>>n;
	double sum=0;
	for(int i=1;i<=n;i++){
		scanf("%lf",&num[i]);
		sum+=num[i]*(n+1-i)*i;
	}
	printf("%.2f",sum);
	return 0;
}
           

繼續閱讀