天天看点

PAT (Advanced Level) Practise 1055 The World's Richest (25) 1055. The World's Richest (25)

1055. The World's Richest (25)

时间限制 400 ms

内存限制 128000 kB

代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line "Case #X:" where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth
      

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output "None".

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50
      

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None      

题意:给你n个人的姓名,年龄和财富,q次询问,每次询问一个年龄范围内财富最多的k个人,若这个年龄范围内的人少于k人,则输出所有人即可,并按财富从大到小输出,财富值相同的,按年龄从小到大,若年龄相同则姓名按字典序排序,若不存在任何一个人则输出None

解题思路:将所有同年龄的人放在同一个vector中,然后将每个vector按题目说的进行排序,每次询问时暴力在年龄范围内找m次

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n, q, m, ma, mi, vis[205];
struct node
{
	char name[10];
	int age, money;
}a[100009];
vector<node>g[205];

bool cmp(node a, node b)
{
	if (a.money != b.money) return a.money > b.money;
	else return strcmp(a.name, b.name) < 0;
}

int main()
{
	while (~scanf("%d%d", &n, &q))
	{
		for (int i = 1; i <= n; i++) scanf("%s%d%d", a[i].name, &a[i].age, &a[i].money), g[a[i].age].push_back(a[i]);
		for (int i = 1; i <= 200; i++) sort(g[i].begin(), g[i].end(), cmp);
		for (int i = 1; i <= q; i++)
		{
			printf("Case #%d:\n", i);
			scanf("%d%d%d", &m, &mi, &ma);
			memset(vis, 0, sizeof vis);
			int flag = 0;
			for (int j = 0; j<m; j++)
			{
				int k = -1;
				for (int p = mi; p <= ma; p++)
				{
					if (vis[p] >= g[p].size()) continue;
					if (k == -1 || g[k][vis[k]].money<g[p][vis[p]].money) k = p;
				}
				if (k == -1) break;
				flag = 1;
				printf("%s %d %d\n", g[k][vis[k]].name, g[k][vis[k]].age, g[k][vis[k]].money);
				vis[k]++;
			}
			if (!flag) printf("None\n");
		}
	}
	return 0;
}