天天看点

Eddy's digital Roots-数论基础

B - Eddy's digital Roots Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit  Status  Practice  HDU 1163

Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39. 

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots. 

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000). 

Output

Output n^n's digital root on a separate line of the output. 

Sample Input

2
4
0 
             

Sample Output

4
4 
             
//九余数定理
//对于一个数的各数位和等于他对9进行取余,当为零的时候则是9
/*
Author: 2486
Memory: 1408 KB		Time: 0 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int main(){
while(~scanf("%d",&n),n){
    int i=n;
    int sum=1;
    while(i--){
        sum*=n;
        sum%=9;
    }
    if(sum==0)printf("9\n");
    else printf("%d\n",sum);
}

return 0;
}
           
//N个整数的乘积总值的数根 = 每个项元素的数根的乘积
/*
Author: 2486
Memory: 1408 KB		Time: 15 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
int rot(int x){
    int sum=0;
    while(x){
        sum+=x%10;
        x/=10;
    }
    if(sum>=10)return rot(sum);
    return sum;
}
int main(){
while(~scanf("%d",&n),n){
    int k=rot(n);
    int ans=1;
    for(int i=0;i<n;i++){
        ans=rot(k*ans);
    }
    printf("%d\n",ans);
}

return 0;
}