天天看点

ACM-简单题之Wolf and Rabbit——hdu1222Wolf and Rabbit

Wolf and Rabbit

Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.

ACM-简单题之Wolf and Rabbit——hdu1222Wolf and Rabbit

A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

Sample Input

2
1 2
2 2
      

Sample Output

NO
YES

题意大概为:狼捉兔子,兔子躲在n个洞中一个,这n个洞围成一个圈,狼会从第0号洞开始,搜索隔m的洞,一直搜索下去,
问是否存在洞另狼永远搜索不到,这样兔子就重获新生。
思路就是求输入的两个数是否互质即最大公约数是否为1.


       
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int m,n,t;
    int k;

    scanf("%d",&t);
    for(;t>0;--t)
    {
        scanf("%d%d",&m,&n);
        
        
        while(n!=0)
        {
            k=m%n;
            m=n;
            n=k;
        }

        if(m!=1)
            printf("YES\n");
        else
            printf("NO\n");


    }
    return 0;
}