1235
统计同成绩学生人数
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21508 Accepted Submission(s): 12163
Problem Description
读入N名学生的成绩,将获得某一给定分数的学生人数输出。
Input
测试输入包含若干测试用例,每个测试用例的格式为
第1行:N
第2行:N名学生的成绩,相邻两数字用一个空格间隔。
第3行:给定分数
当读到N=0时输入结束。其中N不超过1000,成绩分数为(包含)0到100之间的一个整数。
Output
对每个测试用例,将获得给定分数的学生人数输出。
Sample Input
3
80 60 90
60
2
85 66
5
60 75 90 55 75
75
Sample Output
1
2
Hint
Hint
Huge input, scanf is recommended.
Source
浙大计算机研究生复试上机考试-2006年
Recommend
JGShining | We have carefully selected several similar problems for you: 1230 1229 1237 1236 1233
#include<cstdio>
#include<map>
using namespace std;
int main()
{
int n;
while (scanf("%d",&n),n)
{
map<int, int>a;
int m;
while (n--)
{
scanf("%d", &m);
a[m]++;
}
scanf("%d", &m);
printf("%d\n", a[m]);
}
return ;
}