天天看點

hdu 4349 Xiao Ming's Ho

Xiao Ming's Ho

ime Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1155    Accepted Submission(s): 794

Problem Description

Xiao Ming likes counting numbers very much, especially he is fond of counting odd numbers. Maybe he thinks it is the best way to show he is alone without a girl friend. The day 2011.11.11 comes. Seeing classmates walking with their girl friends, he coundn't help running into his classroom, and then opened his maths book preparing to count odd numbers. He looked at his book, then he found a question "C(n,0)+C(n,1)+C(n,2)+...+C(n,n)=?". Of course, Xiao Ming knew the answer, but he didn't care about that , What he wanted to know was that how many odd numbers there were? Then he began to count odd numbers. When n is equal to 1, C(1,0)=C(1,1)=1, there are 2 odd numbers. When n is equal to 2, C(2,0)=C(2,2)=1, there are 2 odd numbers...... Suddenly, he found a girl was watching him counting odd numbers. In order to show his gifts on maths, he wrote several big numbers what n would be equal to, but he found it was impossible to finished his tasks, then he sent a piece of information to you, and wanted you a excellent programmer to help him, he really didn't want to let her down. Can you help him?

Input

Each line contains a integer n(1<=n<=108)

Output

A single line with the number of odd numbers of C(n,0),C(n,1),C(n,2)...C(n,n).

Sample Input

1

2

11

Sample Output

2

2

8

題意

給定n,求C(n, 0) C(n, 1) ……C(n, n)中奇數的個數

解法

數學上有一個二項式系數的定理,即二項式系數中的奇數個數等于2^k(k為n的二進制表示中1的個數)。具體證明可以百度到。至于怎麼算k,我用的lowbit(),相信看過樹狀數組的都知道這個,它表示x的二進制表示中右邊第一個1的值,具體實作見代碼。

我第一次做的時候也沒找到規律,一發現這個定理就秒過。其實這種題多算幾個例子,還是可以觀察出來的。

#include "iostream"
#include "cstdio"
using namespace std;

int lowbit(int x)
{
	return x&(-x);
}

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{
		int k = 1;
		while(n != 0)
		{
			n = n - lowbit(n);
			k = k << 1;
		}

		printf("%d\n", k);

	}
	return 0;
}
           

繼續閱讀