天天看點

HDU 5666 Segment

Problem Description

    Silen August does not like to talk with others.She like to find some interesting problems.

    Today she finds an interesting problem.She finds a segment 

x+y=q.The segment intersect the axis and produce a delta.She links some line between 

(0,0) and the node on the segment whose coordinate are integers.

    Please calculate how many nodes are in the delta and not on the segments,output answer mod P.

Input

    First line has a number,T,means testcase number.

    Then,each line has two integers q,P.

    q is a prime number,and 

2≤q≤1018,1≤P≤1018,1≤T≤10.

Output

Output 1 number to each testcase,answer mod P.      

Sample Input

1
2 107      

Sample Output

import java.io.*;

import java.math.*;

import java.util.*;

import java.text.*;

public class Main

{

    public static void main(String[] args)

    {

        Scanner cin = new Scanner (new BufferedInputStream(System.in));
        int T;
        T=cin.nextInt();
        for(int i=1;i<=T;i++)
        {
            BigInteger a,b;
            a=cin.nextBigInteger();
            b=cin.nextBigInteger();
       System.out.println(a.subtract(BigInteger.valueOf(2)).multiply(a.subtract(BigInteger.ONE)).divide(BigInteger.valueOf(2)).mod(b));
            
        }

    }

}
Close