天天看點

HDU 5373 The shortest problem

Problem Description

In this problem, we should solve an interesting game. At first, we have an integer n, then we begin to make some funny change. We sum up every digit of the n, then insert it to the tail of the number n, then let the new number be the interesting number n. repeat it for t times. When n=123 and t=3 then we can get 123->1236->123612->12361215.

Input

Multiple input.

We have two integer n (0<=n<=

104

 ) , t(0<=t<=

105

) in each row.

When n==-1 and t==-1 mean the end of input.

Output

For each input , if the final number are divisible by 11, output “Yes”, else output ”No”. without quote.

Sample Input

35 2

35 1

-1 -1

Sample Output

Case #1: Yes

Case #2: No

#include<cstdio>
#include<cmath>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn=100005;
LL T,n,m,sum,k;

void insert(LL x)
{
    LL f=1;
    for (LL i=x;i;i/=10)
    {
        sum+=i%10;
        f*=10;
    }
    k=(k*f+x)%11;
}

int main()
{
    int tt=0;
    while (~scanf("%lld%lld",&n,&m),n+m!=-2)
    {
        k=sum=0;
        insert(n);
        while (m--) insert(sum);
        if (k==0) printf("Case #%d: Yes\n",++tt);
        else printf("Case #%d: No\n",++tt);
    }
    return 0;
}