天天看點

HDU 6213-Chinese Zodiac

​​題目傳送門​​

Chinese Zodiac

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 495 Accepted Submission(s): 340

Problem Description

The Chinese Zodiac, known as Sheng Xiao, is based on a twelve-year cycle, each year in the cycle related to an animal sign. These signs are the rat, ox, tiger, rabbit, dragon, snake, horse, sheep, monkey, rooster, dog and pig.

Victoria is married to a younger man, but no one knows the real age difference between the couple. The good news is that she told us their Chinese Zodiac signs. Their years of birth in luner calendar is not the same. Here we can guess a very rough estimate of the minimum age difference between them.

If, for instance, the signs of Victoria and her husband are ox and rabbit respectively, the estimate should be 2 years. But if the signs of the couple is the same, the answer should be 12 years.

Input

The first line of input contains an integer T (1≤T≤1000) indicating the number of test cases.

For each test case a line of two strings describes the signs of Victoria and her husband.

Output

For each test case output an integer in a line.

Sample Input

3

ox rooster

rooster ox

dragon dragon

Sample Output

8

4

12

Source

2017 ACM/ICPC Asia Regional Qingdao Online

題目大意:

一個女的找了一個比自己小的丈夫,沒有人知道他們的年領差,但是知道他們的生肖,問女的至少比男的大多少歲

利用STL的map來做這個題就很友善了。

#include<iostream>
#include<map>
#include<string>
using namespace std;

map<string,int>Map;

int main()
{
    int T;
    Map["rat"]=1;
    Map["ox"]=2;
    Map["tiger"]=3;
    Map["rabbit"]=4;
    Map["dragon"]=5;
    Map["snake"]=6;
    Map["horse"]=7;
    Map["sheep"]=8;
    Map["monkey"]=9;
    Map["rooster"]=10;
    Map["dog"]=11;
    Map["pig"]=12;
    cin>>T; 
    while(T--)
    {
        string N,M;
        cin>>N>>M;
        int Ca;
        if(Map[N]>Map[M])
        {
            Ca=12+Map[M]-Map[N];
        }
        else if(Map[N]==Map[M])
        {
            Ca=12;
        }
        else
        {
            Ca=Map[M]-Map[N];
        }
        printf("%d\n",Ca);
    }
}