天天看點

UVa679(Dropping Balls)(二叉樹的編号)

 Dropping Balls

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, eitherfalse or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag's current value at this node is false, then the ball will first switch this flag's value, i.e., from thefalse to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.

Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of Iwill not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.

For each test cases the range of two parameters D and I is as below: 

Input

Contains 

l

+2 lines.

Line 1 I the number of test cases Line 2

test case #1, two decimal numbers that are separatedby one blank

...

Line k+1

test case #k Line l+1

test case #l Line l+2 -1

Output

Contains l

 lines.

Line 1 the stop position P for the test case #1 ... Line k the stop position P for the test case #k ... Line l the stop position P for the test case #l

Sample Input

54 23 4

10 1

2 2

8 128

-1

Sample Output

127512

3

255

題意:有一個編号為1,2,3,...2^D-1的二叉樹,D為最大深度。且所有葉子的深度都相同,也就是滿二叉樹。在結點1處放一個小球,

它會下落,每個内結點上都有一個開關,初始狀态都為關閉,每次有小球落到開關上時,該開關狀态就會改變。如果小球到達1個結點

時,該結點的開關關閉,則往左走,否則往右走,直到走到葉子結點。輸出給定n個小球中第n個小球最終所在的葉子編号。

對于一個結點k,其左子結點,右子結點的編号分别是2k,2k+1.

如果使用題目中給的編号I,當I是奇數時,它是往左走的第(I+1)/2個小球,當I

是偶數時,它是往右走的第I/2個小球。可以直接模拟最後一個小球的路線。。。

#include<stdio.h>
 int main()
 {
  int test,m,n,k;
  while(scanf("%d",&test)&&test!=-1)
  {
    while(test--)
    {
      scanf("%d%d",&m,&n);
      k=1;
      for(int i=0;i<m-1;i++)
      {
        if(n%2)
        {
          k*=2,n=(n+1)/2;
        }
        else
        {
          k=2*k+1;n/=2;
        } 
      }
      printf("%d\n",k);
     }
   }
 }