天天看點

10494 - If We Were a Child Again

   Uva

10494 - If We Were a Child Again

Problem C

IfWe Were a Child Again

Input: standard input

Output: standard output

Time Limit: 7 seconds

“Oooooooooooooooh!

If I could do the easy mathematics like my school days!!

I can guarantee, that I’d not make any mistake this time!!”

Says a smart university student!!

But his teacher even smarter – “Ok! I’d assign you such projects in your software lab. Don’t be so sad.”

“Really!!” - the students feels happy. And he feels so happy that he cannot see the smile in his teacher’s face.

10494 - If We Were a Child Again

The Problem

The first project for the poor student was to make a calculator that can just perform the basic arithmetic operations.

But like many other university students he doesn’t like to do any project by himself. He just wants to collect programs from here and there. As you are a friend of him, he asks you to write the program. But, you are also intelligent enough to tackle this kind of people. You agreed to write only the (integer) division and mod (% in C/C++) operations for him.

Input

Input is a sequence of lines. Each line will contain an input number. One or more spaces. A sign (division or mod). Again spaces. And another input number. Both the input numbers are non-negative integer. The first one may be arbitrarily long. The second number n will be in the range (0 < n < 231).

Output
A line for each input, each containing an integer. See the sample input and output. Output should not contain any extra space.

    Sample Input

110 / 100

99 % 10

2147483647 / 2147483647

2147483646 % 2147483647

    Sample Output

1

9

1

2147483646

Problemsetter:  S. M. Ashraful Kadir, University ofDhaka

以下測試資料供參考:

輸入:

24969 / 123

100100  / 10

0 / 123

1002 % 10

輸出:

203

10010

2

我也是從這最後一組資料發現錯誤的。

#include <iostream>
#include <string>
#include <cstdio>
using namespace std;

int main()
{
    string s,div;
    char c;
    int n;
//    freopen("a.txt","r",stdin);
    while(cin>>s>>c>>n)
    {
        int j=0;
        long long mod=0;
        for(unsigned i=0;i<s.length();i++)//模拟除法;
        {
            mod=mod*10+s[i]-'0';//mod超int;
            if(mod>=n)
            {
                div[j++]=mod/n+'0';
                mod%=n;
            }
            else
                if(j)
                    div[j++]='0';

        }
        div[j]='\0';
        if(c=='/')
        {
            if(j==0)//第一個數小于第二個數的情況;
                cout<<j<<endl;
            else
                cout<<div.c_str()<<endl;
        }
        else
        {
            if(j==0)
                cout<<s<<endl;
            else
                cout<<mod<<endl;
        }

    }
    return 0;
}