天天看點

PAT甲級----1038 Recover the Smallest Number (30分)1038 Recover the Smallest Number (30分)

1038 Recover the Smallest Number (30分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

這題解法比較獨特,比較的時候隻需要比較a+b和b+a即可,如果a+b拼接出的字元串大于b+a拼接出的字元串,那麼就将b+a放前面,否則将a+b放前面,最後去除前導零即可

#include<bits/stdc++.h>

using namespace std;

int n;
string ss = "";
vector<string>v;
map<string,int>vis,ans;

bool cmp(string a , string b)
{
	return a + b < b + a;
}

int main()
{
	cin >> n;
	for(int i = 0 ; i < n ; i++)
	{
		string s;
		cin >> s;
		v.push_back(s);
	}
	sort(v.begin(),v.end(),cmp);
	string ans = "";
	for(int i = 0 ; i < v.size() ; i++)
		ans += v[i];
	int i = 0;
	while(ans[i] == '0' && i < ans.size())
		i++;
	string ans2 = "";
	for(int j = i ; j < ans.size() ; j++)
		ans2 += ans[j];
	if(!ans2.size())
		cout << "0";
	else
		cout << ans2;
	return 0;
}