天天看點

UVA-712 S-Trees

挺簡單的一道題,就是在處理輸入的時候遇到了一些問題,本來是用的 scant讀入,但是不知道為什麼的會讀錯個數,換成cin解決問題,以前也遇到過一次這種情況,是這種讀入多種資料類型的情況,scanf會有問題,改用cin

題目的思路就是存一下往左還是往右走,計算出最後的編号,往左右就是num * 2,往右走就是num * 2 + 1,然後查詢一下這個位置的值就可以,wrong的一次是沒有注意兩組之間的空行 

A Strange Tree (S-tree) over the variable set Xn = {x1, x2, . . . , xn} is a binary tree representing aBoolean function f : {0,1}n → {0,1}. Each path of the S-tree begins at the root node and consistsof n + 1 nodes. Each of the S-tree’s nodes has a depth, which is the amount of nodes between itselfand the root (so the root has depth 0). The nodes with depth less than n are called non-terminalnodes. All non-terminal nodes have two children: the right child and the left child. Each non-terminalnode is marked with some variable xi from the variable set Xn. All non-terminal nodes with the samedepth are marked with the same variable, and non-terminal nodes with di erent depth are marked withdi erent variables. So, there is a unique variable xi1 corresponding to the root, a unique variable xi2corresponding to the nodes with depth 1, and so on. The sequence of the variables xi1 , xi2 , . . ., xinis called the variable ordering. The nodes having depth n are called terminal nodes. They have nochildren and are marked with either 0 or 1. Note that the variable ordering and the distribution of 0’sand 1’s on terminal nodes are su cient to completely describe an S-tree.

As stated earlier, each S-tree represents a Boolean function f. If you have an S-tree and values forthe variables x1, x2, ..., xn, then it is quite simple to nd out what f(x1,x2,...,xn) is: start with theroot. Now repeat the following: if the node you are at is labelled with a variable xi, then depending onwhether the value of the variable is 1 or 0, you go its right or left child, respectively. Once you reach aterminal node, its label gives the value of the function.

Figure 1: S-trees for the function x1 ∧ (x2 ∨ x3)

On the picture, two S-trees representing the same Boolean function, f(x1, x2, x3) = x1 ∧ (x2 ∨ x3),are shown. For the left tree, the variable ordering is x1, x2, x3, and for the right tree it is x3, x1, x2.

The values of the variables x1, x2, ..., xn, are given as a Variable Values Assignment (VVA)(x1 = b1,x2 = b2,...,xn = bn)

with b1,b2,...,bn ∈ {0,1}. For instance, (x1 = 1, x2 = 1, x3 = 0) would be a valid VVA for n = 3,resulting for the sample function above in the value f (1, 1, 0) = 1 ∧ (1 ∨ 0) = 1. The correspondingpaths are shown bold in the picture.

Your task is to write a program which takes an S-tree and some VVAs and computes f (x1 , x2 , . . . , xn )as described above.

Input

The input le contains the description of several S-trees with associated VVAs which you have toprocess. Each description begins with a line containing a single integer n, 1 ≤ n ≤ 7, the depth of theS-tree. This is followed by a line describing the variable ordering of the S-tree. The format of that lineis xi1 xi2 . . . xin . (There will be exactly n di erent space-separated strings). So, for n = 3 and thevariable ordering x3, x1, x2, this line would look as follows:

x3 x1 x2

In the next line the distribution of 0’s and 1’s over the terminal nodes is given. There will be exactly2n characters (each of which can be ‘0’ or ‘1’), followed by the new-line character. The characters aregiven in the order in which they appear in the S-tree, the rst character corresponds to the leftmostterminal node of the S-tree, the last one to its rightmost terminal node.

The next line contains a single integer m, the number of VVAs, followed by m lines describingthem. Each of the m lines contains exactly n characters (each of which can be ‘0’ or ‘1’), followedby a new-line character. Regardless of the variable ordering of the S-tree, the rst character alwaysdescribes the value of x1, the second character describes the value of x2, and so on. So, the line

110

corresponds to the VVA (x1 = 1, x2 = 1, x3 = 0).

The input is terminated by a test case starting with n = 0. This test case should not be processed.

Output

For each S-tree, output the line ‘S-Tree #j:’, where j is the number of the S-tree. Then print a linethat contains the value of f(x1,x2,...,xn) for each of the given m VVAs, where f is the functionde ned by the S-tree.

Output a blank line after each test case.

Sample Input

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0
      

Sample Output

S-Tree #1:
0011
      
S-Tree #2:
0011
      
//NCC_31060 Majestic
#include <iostream>
#include <deque>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <stack>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cstdio>
#include <cmath>
#include <cstdlib>

using namespace std;

#define input(a) scanf("%d",&a);
#define print_one_blank printf(" ");

int n;
string value;
int order[8];

void Init() {
    for (int i = 0; i < n; ++i) {
        string s;
        cin >> s;
        order[i] = s[1] - '0';
    }
    cin >> value;
}

void Cal_Value() {
    string move;
    cin >> move;
    int pos = 1;
    int head = 1;
    for (int i = 0; i < n; ++i) {
        if (move[order[i] - 1] == '0')pos *= 2;
        else pos = pos * 2 + 1;
        head *= 2;
    }
    pos = pos - head;
    printf("%c", value[pos]);
}

int main() {
#ifdef LOCAL
    freopen("IN.txt", "r", stdin);
#endif
    int cases = 1;
    while (scanf("%d", &n) != EOF) {
        if(n == 0)break;
        Init();
        int m;
        scanf("%d", &m);
        printf("S-Tree #%d:\n",cases++);
        for (int i = 0; i < m; ++i) {
            Cal_Value();
        }
        printf("\n\n");
    }
    return 0;
}
           
上一篇: 712 - S-Trees
下一篇: UVa712 S-Trees