天天看點

POJ 1979 Red and Black (DFS水題)

今天确實是值得紀念的一天

終究決定重拾放下了很久(幾個月)的ACM

跟着老師做了幾個月IOS,做出了自己的第一個APP(我負責是前端)

雖然很low,但終究是自己的第一個APP作品,在杭州的寒冬唯一能讓我感到溫暖的也就隻有這個了

忙完這個之後,就開始準備3月的ACM校賽了

1個多月時間...還是太短了點,先做道水題熱熱身

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0      

Sample Output

45
59
6
13
      

題目描述:意思就是你處在@點,#點無法通過,問最多能走過多少的.點(可以重複走)。

思路:每走一步,DFS一遍即可。

#include <cstdio>
#include <cstdlib>
#include <iostream>
using namespace std;
int m,n;
int _x,_y;
char map[21][21];
int visited[21][21];//标記是否經過 
int cut=0;//總步數 
bool check(int i,int j){
	if(map[i][j]=='.'&&i<m&&j<n&&i>=0&&j>=0&&visited[i][j]==0)
		return true;
	return false;
}
void DFS(int x,int y){
	cut++;
	visited[x][y]=1;
	if(check(x+1,y)) DFS(x+1,y);
	if(check(x-1,y)) DFS(x-1,y);
	if(check(x,y+1)) DFS(x,y+1);
	if(check(x,y-1)) DFS(x,y-1);
}
int main(void){
	while(cin>>m>>n,m,n){
		int t;//注意這題先輸入列再輸入行! 
		t=m;
		m=n;
		n=t;
		cut=0;
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++){
				cin>>map[i][j];
				if(map[i][j]=='@'){//标記出發點 
					_x=i;
					_y=j;
					map[i][j]='.';
				}
			}
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				visited[i][j]=0;
				
		DFS(_x,_y);
		cout<<cut<<endl;
	}
	return 0;
}
           

繼續閱讀