天天看點

杭電1008-Elevator Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 53208    Accepted Submission(s): 29402

Problem Description The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output Print the total time on a single line for each test case. 

Sample Input

1 2
3 2 3 1
0
        

Sample Output

17
41
        

這是個簡單的數學計算題!

AC代碼:

#include<cstdio>
int main()
{
	int a,n,i,b,t,time;
	while(scanf("%d",&n),n)
	{
		time=0;
		t=0;
		time+=n*5;//停止用的時間
		for(i=0;i<n;i++)
		{
			scanf("%d",&a);
			if(a>t)
			 time+=(a-t)*6;//每次和前一個比較若是上樓,則一層加6
			 else
			 time+=(t-a)*4;//下一層加4
			 t=a;
		 } 
		 printf("%d\n",time); 
	 } 
	 return 0;
 }