天天看點

HDU 4465 Candy(機率)

Problem Description LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.

He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?  

Input There are several test cases.

For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).

Input is terminated by EOF.  

Output For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.

Any answer with an absolute error less than or equal to 10 -4 would be accepted.  

Sample Input

10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000
        

Sample Output

Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000
        

Source 2012 Asia Chengdu Regional Contest   分析:枚舉還剩i個A(B)鐘即可,這種題見得少,其實就是機率論裡練習題的水準, 但是要組合數,注意到n達1e5,無法勝任,還是要取log

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<string>
#include<iostream>
#include<queue>
#include<cmath>
#include<map>
#include<stack>
#include<set>
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const int INF=0x3f3f3f3f;
typedef long long LL;
const int maxn=(1e5+100)*2;
int n;
double p;
double f[maxn*2+100];

int main()
{
    f[0]=0;
    for(int i=1;i<=maxn*2;i++)
        f[i]=f[i-1]+log(1.0*i);
    int cas=1;
    while(~scanf("%d%lf",&n,&p))
    {
        double sum=0.0;
        for(int i=1;i<=n;i++)//枚舉還剩i個
        {
            double A=(f[2*n-i]-f[n-i]-f[n])+(n-i)*log(p)+(n+1)*log(1-p);
            double B=(f[2*n-i]-f[n-i]-f[n])+(n-i)*log(1-p)+(n+1)*log(p);
            sum+=(exp(A)+exp(B))*i;
        }
        printf("Case %d: %.6f\n",cas++,sum);
    }
    return 0;
}