天天看點

POJ1200 A - Crazy Search(哈希)

​​A - Crazy Search​​

Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle. 

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text. 

As an example, consider N=3, NC=4 and the text "daababac". The different substrings of size 3 that can be found in this text are: "daa"; "aab"; "aba"; "bab"; "bac". Therefore, the answer should be 5. 

Input

The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output

The program should output just an integer corresponding to the number of different substrings of size N found in the given text.

Sample Input

3 4
daababac      

Sample Output

5      

Hint

Huge input,scanf is recommended.

  題意:給出兩個數n,nc,并給出一個由nc種字元組成的字元串。求這個字元串中長度為n的子串有多少種。

  先将每個不同字母轉化為一個數。再根據此将每一個字串轉化為一個數,存入hash表裡。存的方法是:每一個字串是一個連續的數,nc(不同字母數)作用就在這裡。把這串連續的數轉化為nc進制數,然後判斷存在就可以了.

#include<iostream>          
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const int maxn=16000005;
ll hash[maxn],num[29];
char s[maxn];
int main()
{
    ll n,m;
    while(~scanf("%lld%lld%s",&n,&m,s))
    {
    //    memset(hash,0,sizeof(hash));
    //    memset(num,0,sizeof(num));
        ll len=strlen(s);
        ll cnt=0;
        num[s[0]]=cnt++;
        for(int i=1;i<len;i++)
        {
            if(num[s[i]]==0)
                num[s[i]]=cnt++;
        }    
        ll ans=0;
        for(int i=0;i<=len-n;i++)
        {
            ll sum=0;
            for(int j=0;j<n;j++)
            {
                sum=sum*m+num[s[i+j]];
            //    printf("%lld * %lld+%lld     ",sum,m,num[s[i+j]]);
            }
            if(!hash[sum])
            {
                ans++;
        //        printf("hash[sum]:%lld  sum:%lld \n",hash[sum],sum);
                hash[sum]=1;
            }
        }
        printf("%lld\n",ans);
    }    
    return 0;
}