天天看點

1063 Set Similarity (25point(s)) - PAT 甲級 C語言

1063 Set Similarity (25point(s))

Given two sets of integers, the similarity of the sets is defined to be Nc / Nt × 100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤ 50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤ 104) and followed by M integers in the range [0,109]. After the input of sets, a positive integer K (≤ 2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3

3 99 87 101

4 87 101 5 87

7 99 101 18 5 135 18 99

2

1 2

1 3

Sample Output:

50.0%

33.3%

題目大意:

給多個集合,多次查詢兩個集合,輸出每次查詢的兩個集合的相似度

Nc / Nt * 100%

,Nc 為兩集合中公共元素的個數,Nt 為兩集合中不同元素的總個數,即 Nc 為兩集合的交集,Nt 為并集

設計思路:
  • 對每個集合排序去重,
  • 經過排序,集合元素有序,查詢兩集合時,用兩個指針從前往後周遊集合
    • 兩指針元素相同,兩指針同時向後走,Nc 和 Nt 均加 1
    • 指針元素不同,誰小誰向後走,僅 Nt 加 1
    • 最後将 Nt 加上未周遊完集合的剩餘元素個數
  • 輸出查詢結果
編譯器:C (gcc)
#include <stdio.h>

int cmp(const void *a, const void *b)
{
        return *((int *)a) - *((int *)b);
}

int sort_uniq(int arr[], int n)
{
        int i, j;
        qsort(arr, n, sizeof(arr[0]), cmp);

        for (i = 1, j = 0; i < n; i++) {
                if (arr[i] != arr[j]) {
                        arr[++j] = arr[i];
                }
        }
        return j + 1;
}

int main(void) {
        int n, m, k;
        int sets[50][10001] = {0}, count[50] = {0};
        int i, j, temp;
        int a, b, nc, nt;

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &m);
                for (j = 0; j < m; j++) {
                        scanf("%d", &sets[i][j]);
                }
                count[i] = sort_uniq(sets[i], m);
        }

        scanf("%d", &k);
        for (m = 0; m < k; m++) {
                scanf("%d %d", &a, &b);
                a--;
                b--;
                nc = 0;
                nt = 0;
                for (i = 0, j = 0; i < count[a] && j < count[b];) {
                        if (sets[a][i] == sets[b][j]) {
                                nc++;
                                nt++;
                                i++;
                                j++;
                        } else {
                                nt++;
                                if (sets[a][i] < sets[b][j])
                                        i++;
                                else
                                        j++;
                        }
                }
                if (i < count[a])
                        nt = nt + count[a] - i;
                else
                        nt = nt + count[b] - j;
                printf("%.1f%%\n", (double)nc / nt * 100);
        }
        return 0;
}
           

繼續閱讀