天天看點

1146 Topological Order (25point(s)) - C語言 PAT 甲級

1146 Topological Order (25point(s))

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

1146 Topological Order (25point(s)) - C語言 PAT 甲級
Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8

1 2

1 3

5 2

5 4

2 3

2 6

3 4

6 4

5

1 5 2 3 6 4

5 1 2 6 3 4

5 1 2 3 6 4

5 2 1 6 3 4

1 2 3 4 5 6

Sample Output:
3 4
題目大意:

輸入 N 個節點,M 條有向邊的有向圖,查詢 K 個序列,判斷所給序列是否為拓撲排序

輸出不是拓撲排序的序列号

設計思路:
  • 儲存每個節點的入度
  • 當到達某節點時,将此節點能到達的節點入度減 1
  • 周遊所給序列節點時,有入度不為 0 的節點,說明不是拓撲排序
編譯器:C (gcc)
#include <stdio.h>

int graph[1010][1010] = {0}, cnt[1010] = {0};

int main(void)
{
        int n, m, k;
        int degree[1010] = {0};
        int i, j, a, b;

        scanf("%d %d", &n, &m);
        for (i = 0; i < m; i++) {
                scanf("%d%d", &a, &b);
                graph[a][cnt[a]] = b;
                cnt[a]++;
                degree[b]++;
        }
        int t, space = 0, temp[1010];
        scanf("%d", &k);
        for (i = 0; i < k; i++) {
                for (j = 1; j <= n; j++)
                        temp[j] = degree[j];
                for (j = 0; j < n; j++) {
                        scanf("%d", &a);
                        if (temp[a] != 0) {
                                printf("%s%d", space == 1 ? " ": "", i);
                                space = 1;
                                for (j++; j < n; j++)
                                        scanf("%d", &a);
                                break;
                        }
                        for (t = 0; t < cnt[a]; t++)
                                temp[graph[a][t]]--;
                }
        }

        return 0;
}
           

繼續閱讀