天天看點

hdu Number Sequence

​​點選打開連結​​   密碼:syuct

Number Sequence

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 9   Accepted Submission(s) : 2

Times New Roman | Verdana | Georgia

← →

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0      

Sample Output

2

5

周期,因為資料特别大,又是mod,是以應該有規律,但是這個隻判斷兩個就斷定是規律了,正常的遞歸超出記憶體。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int s[100000005];
int main()
{
    int a,b,n;
    int i,j;
    s[1]=1;
    s[2]=1;
    while(scanf("%d%d%d",&a,&b,&n))
    {
        if(a==0&&b==0&&n==0)
            break;
        int ans=0;//記錄周期
        for(i=3;i<=n;i++)
        {
            s[i]=(a*s[i-1]+b*s[i-2])%7;
            for(j=2;j<i;j++)
            {
                if(s[j-1]==s[i-1]&&s[j]==s[i])
                {
                    ans=i-j;
                    break;
                }
            }
            if(ans>0)
                break;
        }
        if(ans>0)
            s[n]=s[(n-j)%ans+j];
        cout<<s[n]<<endl;
    }
    return 0;
}