天天看點

Moo University - Financial Aid - poj2010 - 二分搜尋+優先隊列

Moo University - Financial Aid

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11721 Accepted: 3463

Description

Bessie noted that although humans have many universities they can attend, cows have none. To remedy this problem, she and her fellow cows formed a new university called The University of Wisconsin-Farmside,"Moo U" for short. 

Not wishing to admit dumber-than-average cows, the founders created an incredibly precise admission exam called the Cow Scholastic Aptitude Test (CSAT) that yields scores in the range 1..2,000,000,000. 

Moo U is very expensive to attend; not all calves can afford it.In fact, most calves need some sort of financial aid (0 <= aid <=100,000). The government does not provide scholarships to calves,so all the money must come from the university's limited fund (whose total money is F, 0 <= F <= 2,000,000,000). 

Worse still, Moo U only has classrooms for an odd number N (1 <= N <= 19,999) of the C (N <= C <= 100,000) calves who have applied.Bessie wants to admit exactly N calves in order to maximize educational opportunity. She still wants the median CSAT score of the admitted calves to be as high as possible. 

Recall that the median of a set of integers whose size is odd is the middle value when they are sorted. For example, the median of the set {3, 8, 9, 7, 5} is 7, as there are exactly two values above 7 and exactly two values below it. 

Given the score and required financial aid for each calf that applies, the total number of calves to accept, and the total amount of money Bessie has for financial aid, determine the maximum median score Bessie can obtain by carefully admitting an optimal set of calves. 

Input

* Line 1: Three space-separated integers N, C, and F 

* Lines 2..C+1: Two space-separated integers per line. The first is the calf's CSAT score; the second integer is the required amount of financial aid the calf needs 

Output

* Line 1: A single integer, the maximum median score that Bessie can achieve. If there is insufficient money to admit N calves,output -1. 

Sample Input

3 5 70
30 25
50 21
20 20
5 18
35 30
           

Sample Output

35
           

Hint

Sample output:If Bessie accepts the calves with CSAT scores of 5, 35, and 50, the median is 35. The total financial aid required is 18 + 30 + 21 = 69 <= 70. 

Source

USACO 2004 March Green

思路:

終于把這個題過了,hiahiahia~,在第二章碰見的時候還不會寫,一直逾時,學了3.1二分以後就有思路了,因為書上給的例子大多是二分所求的值,是以對于首刷這類題沒經驗的我,一開始想到的就是(0~2.000.000.000)枚舉中位數,樣例過了,但就是WA,然後看了網上說的是二分數組下标,把數組按分數從小到大,(0,c)枚舉數組下标,每次枚舉都判斷是否成立,成立的話left=mid,反之right=mid。最後終于AC了~

代碼如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
using namespace std;
const int maxc=100005,INF=2000000000;
int n,c,f,q;
struct A{
	int score,aid;
}cow[maxc];
int g[maxc];
bool cmp(A a,A b){//按分數從小到大排序 
	return a.score<b.score;
}

bool C(int i){//用i位置上的score做為中位數行不行 
    int sum=f-cow[i].aid;
	priority_queue<int,vector<int>,greater<int> >low;
	priority_queue<int,vector<int>,greater<int> >high;
	for(int j=0;j<i;j++){
		low.push(cow[j].aid);
	}
	for(int j=i+1;j<c;j++){
		high.push(cow[j].aid);
	}
	for(int j=0;j<q;j++){
		int t1=low.top(),t2=high.top();
		low.pop();high.pop();
		sum-=(t1+t2);
		if(sum<0)break;
	}
	if(sum>=0)return true;
	else return false; 
}

int main(){
	scanf("%d%d%d",&n,&c,&f);
	for(int i=0;i<c;i++){
		scanf("%d%d",&cow[i].score,&cow[i].aid);
		g[i]=cow[i].score;
	}
	sort(cow,cow+c,cmp);
	sort(g,g+c);
	int left=0,right=c-1;
	q=n/2;
	while(right-left>1){//枚舉最大的中位數的下标
		int mid=(left+right)/2;
		if(mid>=q&&(c-mid-1)>=q&&C(mid))left=mid;
		else right=mid; 
	}
	int ans;
	if(!left)ans=-1;
	else ans=cow[left].score;
	printf("%d\n",ans);
}
           

錯誤代碼:

(有沒有大佬路過給我說說為啥QwQ)

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstring>
#include<string>
#include<vector>
#include<queue>
using namespace std;
const int maxc=100005,INF=2000000000;
int n,c,f;
struct A{
	int score,aid;
}cow[maxc];
int g[maxc];
bool cmp(A a,A b){//按分數從小到大排序 
	return a.score<b.score;
}

bool C(int s){//要求平均分>=x 
    if(cow[c-1].score<s)return false;
    int q=n/2;
	for(int i=0;i<c;i++){
		if(cow[i].score>=s&&i>=q&&(c-i-1)>=q){
			int sum=f-cow[i].aid;
			priority_queue<int,vector<int>,greater<int> >low;
			priority_queue<int,vector<int>,greater<int> >high;
			for(int j=0;j<i;j++){
				low.push(cow[j].aid);
			}
			for(int j=i+1;j<c;j++){
				high.push(cow[j].aid);
			}
			for(int j=0;j<q;j++){
				int t1=low.top(),t2=high.top();
				low.pop();high.pop();
				sum-=(t1+t2);
				if(sum<0)break;
			}
			if(sum>=0)return true;
		}
	} 
	return false;
} 

int main(){
	scanf("%d%d%d",&n,&c,&f);
	for(int i=0;i<c;i++){
		scanf("%d%d",&cow[i].score,&cow[i].aid);
		g[i]=cow[i].score;
	}
	sort(cow,cow+c,cmp);
	sort(g,g+c);
	int left=0,right=INF;
	while(right-left>1){//枚舉最大的中位數,中位數>=mid 
		int mid=(left+right)/2;
		if(C(mid))left=mid;
		else right=mid; 
	}
	int ans;
	if(!left)ans=-1;
	else ans=*lower_bound(g,g+c,left);
	printf("%d\n",ans);
}
           

繼續閱讀