天天看點

HDU 1698 Just a Hook (區間更新+延遲标記)Just a Hook

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 31096    Accepted Submission(s): 15313

Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

HDU 1698 Just a Hook (區間更新+延遲标記)Just a Hook

Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.   Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.   Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.   Sample Input 1 10 2 1 5 2 5 9 3   Sample Output Case 1: The total value of the hook is 24.    

/*
題意:
n的數初始值為銅(1),然後把x到y之内的所有值都更新為z,
求最後的總值! (線段樹的區間更新,外加延遲标記)
*/
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long LL;
const LL N = 100000;
int n, a, b, z;
typedef struct Node {
    int l, r, sum;
    int lazy, tag;
} Tr;
Tr x[5 * N];
/*  建立線段樹   */
void creat(int d, int l, int r)
{
    x[d].l = l;
    x[d].r = r;
    x[d].lazy = x[d].tag = 0;
    if(l == r) {
        x[d].sum = 1;
        return ;
    }
    int m = (l + r) / 2;
    creat(2 * d, l, m);
    creat(2 * d + 1, m + 1, r);
    x[d].sum = x[2 * d].sum + x[2 * d + 1].sum;
}
/*  區間更新子產品    */
void update(int d, int l, int r, int v)
{
    if(x[d].l == l && x[d].r == r) {
        x[d].lazy = 1;
        x[d].tag = v;
        x[d].sum = (r - l + 1) * v;
        return;
    }
    int m = (x[d].l + x[d].r) / 2;
    if(x[d].lazy == 1) {
        x[d].lazy = 0;
        update(d * 2, x[d].l, m, x[d].tag);
        update(d * 2 + 1, m + 1, x[d].r, x[d].tag);
        x[d].tag = 0;
    }
    if(r <= m)
        update(d * 2, l, r, v);
    else if(l > m)
        update(d * 2 + 1, l, r, v);
    else {
        update(d * 2, l, m, v);
        update(d * 2 + 1, m + 1, r, v);
    }
    x[d].sum = x[d * 2].sum + x[2 * d + 1].sum;
}
int main()
{
    int m, T;
    while(~scanf("%d", &T)) {
        for(int it = 1; it <= T; it++) {
            scanf("%d%d", &n, &m);
            creat(1, 1, n);
            while(m--) {
                scanf("%d%d%d", &a, &b, &z);
                update(1, a, b, z);
            }
            printf("Case %d: The total value of the hook is %d.\n", it, x[1].sum);
        }
    }
    return 0;
}      

轉載于:https://www.cnblogs.com/yu0111/p/6710954.html