天天看點

HDU 4920 Matrix multiplication(矩陣乘法,cin,cout逾時呀) Matrix multiplication

Matrix multiplication

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 3989    Accepted Submission(s): 1624

Problem Description Given two matrices A and B of size n×n, find the product of them.

bobo hates big integers. So you are only asked to find the result modulo 3.  

Input The input consists of several tests. For each tests:

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A ij. The next n lines describe the matrix B in similar format (0≤A ij,B ij≤10 9).  

Output For each tests:

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.  

Sample Input

1
0
1
2
0 1
2 3
4 5
6 7
        

Sample Output

0
0 1
2 1
        

Author Xiaoxu Guo (ftiasch)  

Source

2014 Multi-University Training Contest 5

原題連結:http://acm.hdu.edu.cn/showproblem.php?pid=4920

題意:就是兩個矩陣相乘。

PS:這題原來最先在微信上看到别人的題解,主要解決逾時,看了他的思路來寫,還是逾時,最後又在網上找了别人的代碼看了一下,原來是這題的資料有點多,用cin和cout逾時。

AC代碼

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define MAXN 805
int a[MAXN][MAXN],b[MAXN][MAXN],c[MAXN][MAXN];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int x;
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                //cin>>x;
                scanf("%d",&x);
                a[i][j]=x%3;
            }
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                //cin>>x;
                scanf("%d",&x);
                b[i][j]=x%3;
            }
        memset(c,0,sizeof(c));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                for(int k=0; k<n; k++)
                {
                    c[i][j]+=a[i][k]*b[k][j];
                }
            }
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(j)
                    printf(" ");
                    //cout<<" ";
                //cout<<c[i][j]%3;
                printf("%d",c[i][j]%3);
            }
            //cout<<endl;
            printf("\n");
        }
    }
    return 0;
}