天天看點

HDU2767 Proving EquivalencesProving Equivalences

Proving Equivalences

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 3027 Accepted Submission(s): 1133

Problem Description

Consider the following exercise, found in a generic linear algebra textbook.

Let A be an n × n matrix. Prove that the following statements are equivalent:

1. A is invertible.

2. Ax = b has exactly one solution for every n × 1 matrix b.

3. Ax = b is consistent for every n × 1 matrix b.

4. Ax = 0 has only the trivial solution x = 0.

The typical way to solve such an exercise is to show a series of implications. For instance, one can proceed by showing that (a) implies (b), that (b) implies (c), that (c) implies (d), and finally that (d) implies (a). These four implications show that the four statements are equivalent.

Another way would be to show that (a) is equivalent to (b) (by proving that (a) implies (b) and that (b) implies (a)), that (b) is equivalent to (c), and that (c) is equivalent to (d). However, this way requires proving six implications, which is clearly a lot more work than just proving four implications!

I have been given some similar tasks, and have already started proving some implications. Now I wonder, how many more implications do I have to prove? Can you help me determine this?

Input

On the first line one positive number: the number of testcases, at most 100. After that per testcase:

* One line containing two integers n (1 ≤ n ≤ 20000) and m (0 ≤ m ≤ 50000): the number of statements and the number of implications that have already been proved.

* m lines with two integers s1 and s2 (1 ≤ s1, s2 ≤ n and s1 ≠ s2) each, indicating that it has been proved that statement s1 implies statement s2.

Output

Per testcase:

* One line with the minimum number of additional implications that need to be proved in order to prove that all statements are equivalent.

Sample Input

2

4 0

3 2

1 2

1 3

Sample Output

4

2

Source

NWERC 2008

題意:要完成n個命題的等價性證明,以進行了m次,問最少還要幾次。

應該算一個強連通的模闆題,把每個強連通分量看成一個點,再看出度為0,入度為0中這兩個鐘最大的就是答案。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<stack>
using namespace std;
const int MAXN=20010;
vector<int> G[MAXN];
int DFN[MAXN],LOW[MAXN],sccno[MAXN],dfs_clock,scc_cnt;
stack<int> S;
void dfs(int u)
{
    DFN[u]=LOW[u]=++dfs_clock;  //圖的每個節點标号
    S.push(u);  //每搜到一個節點,就入棧
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i];
        if(!DFN[v]) //u和v相連,v不在棧中,是以u的low值為u和v中小的一個
        {
            dfs(v);
            LOW[u]=min(LOW[u],LOW[v]);
        }
        else if(!sccno[v])  //注意這裡是在棧中,sccno不為0就說明已經出棧了
        {
            LOW[u]=min(LOW[u],DFN[v]);
        }
    }
    if(LOW[u]==DFN[u])  //u是強連通分量
    {
        scc_cnt++;
        while(1)
        {
            int x=S.top();  //退棧
            S.pop();
            sccno[x]=scc_cnt;
            if(x==u)
                break;
        }
    }
}
int in[MAXN],out[MAXN];
int main()
{
    int t,n,m,i;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            G[i].clear();
        int u,v;
        while(m--)
        {
            scanf("%d%d",&u,&v);
            G[u].push_back(v);
        }
        dfs_clock=scc_cnt=0;
        memset(DFN,0,sizeof(DFN));
        memset(sccno,0,sizeof(sccno));
        for(i=1;i<=n;i++)
            if(!DFN[i])
            dfs(i);
        if(scc_cnt==1)
        {
            printf("0\n");
            continue;
        }
        for(i=1;i<=scc_cnt;i++)
        {
            in[i]=out[i]=1;
        }
        for(u=1;u<=n;u++)
        {
            for(i=0;i<G[u].size();i++)
            {
                v=G[u][i];
                if(sccno[u]!=sccno[v])
                    in[sccno[v]]=out[sccno[u]]=0;
            }
        }
        int a=0,b=0;
        for(i=1;i<=scc_cnt;i++)
        {
            if(in[i])
                a++;
            if(out[i])
                b++;
        }
        int ans=max(a,b);
        printf("%d\n",ans);
    }
    return 0;
}