天天看點

【POJ 1026】Cipher(置換群)

Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21051 Accepted: 5770

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
      
Sample Output
BolHeol  b
C RCE

      

Source

Central Europe 1995

[Submit]   [Go Back]   [Status]   [Discuss]

[題意][給定排列方式,求m輪後的序列,多組測試樣例,每組包含多個序列,輸出時每個序列一行,每組測試樣例之間有一個空行]

【題解】【置換群】

【求出每個循環節,因為是循環的,是以每隔幾次就會回到原位置,用總共要進行的輪數mod循環一次所用的輪數來求m輪後目前字元的位置】

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,a[1010],cnt[1010],num[1010],ans[1010],m,len;
char s[1010];
bool p[1010];
int main()
{
	int i,j;
	while((scanf("%d",&n)==1)&&n)
	 {
	 	memset(a,0,sizeof(a));
	 	memset(cnt,0,sizeof(cnt)); 
	 	int maxn=0;
		for(i=1;i<=n;++i) 
		 {scanf("%d",&a[i]); cnt[a[i]]++; maxn=max(maxn,a[i]); }
	    for(i=1;i<=maxn;++i) 
		   cnt[i]+=cnt[i-1];
	    while((scanf("%d",&m)==1)&&m)
	      {
	 	   memset(ans,0,sizeof(ans));
	 	   memset(num,0,sizeof(num));
	 	   memset(p,0,sizeof(p)); 
	 	   gets(s); len=strlen(s);
	 	   for(i=len;i<=n;++i) s[i]=' ';
	 	   for(i=1;i<=n;++i)
	 	    if(!p[i])
	 	     {
	 	  	  j=i;int t=0;
			  while(!p[j])
			   { t++; num[t]=j;
			    p[j]=1; j=cnt[a[j]]; } 
			  for(j=1;j<=t;++j)
			  ans[num[(j+m-1)%t+1]]=num[j]; 
		    }
		   for(i=1;i<=n;++i) printf("%c",s[ans[i]]);
		   printf("\n");
	    }
	    printf("\n");
	 }
	return 0;
}
           

(剛開始沒讀清題意的窩錯個不停……哎,要好好學英語啊)