天天看點

[ACM] POJ 2000 Gold Coins

Gold Coins

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 20913 Accepted: 13098

Description

The king pays his loyal knight in gold coins. On the first day of his service, the knight receives one gold coin. On each of the next two days (the second and third days of service), the knight receives two gold coins. On each of the next three days (the fourth, fifth, and sixth days of service), the knight receives three gold coins. On each of the next four days (the seventh, eighth, ninth, and tenth days of service), the knight receives four gold coins. This pattern of payments will continue indefinitely: after receiving N gold coins on each of N consecutive days, the knight will receive N+1 gold coins on each of the next N+1 consecutive days, where N is any positive integer.

Your program will determine the total number of gold coins paid to the knight in any given number of days (starting from Day 1).

Input

The input contains at least one, but no more than 21 lines. Each line of the input file (except the last one) contains data for one test case of the problem, consisting of exactly one integer (in the range 1..10000), representing the number of days. The end of the input is signaled by a line containing the number 0.

Output

There is exactly one line of output for each test case. This line contains the number of days from the corresponding line of input, followed by one blank space and the total number of gold coins paid to the knight in the given number of days, starting with Day 1.

Sample Input

10
6
7
11
15
16
100
10000
1000
21
22
0
      

Sample Output

10 30
6 14
7 18
11 35
15 55
16 61
100 945
10000 942820
1000 29820
21 91
22 98
      

Source

Rocky Mountain 2004

解題思路:

題意為 第一天獲得1個硬币,後兩天每天獲得兩個硬币,後三天每天獲得三個硬币:如前6天每天獲得的硬币數為 1 2 2 3 3 3

問第n天一共獲得多少硬币。思路為判斷第n天包括幾個連續的時間段(比如獲得1硬币的一天 獲得2硬币的兩天 獲得3硬币的三天)以及多出來不是一個完整的時間段的那幾天,代碼中用extra,并記錄下多出來的這幾天是第幾個連續時間段。總金币= 完整時間段獲得的+ 餘下的天數獲得的

代碼:

#include <queue>
#include <iostream>
#include <string.h>
#include <stack>
#include <iomanip>
#include <cmath>
using namespace std;

int cnt(int n)
{
    int totalday=0;
    int get=0;
    int i;
    int extra;//不是一個完整的連續i天的那幾天,比如1 2 2 3,extra則為1,獲得3個硬币的那一天
    for(i=1;i<=n;i++)
    {
        totalday+=i;
        if(totalday>n)
        {
            extra=n-(totalday-i);
            break;
        }
        get+=i*i;
    }
    get+=extra*i;
    return get;
}

int main()
{
    int n;
    while(cin>>n&&n)
    {
        cout<<n<<" "<<cnt(n)<<endl;
    }
    return 0;
}