天天看點

POJ2100 Graveyard Design【尺取法】

Graveyard Design

Time Limit: 10000MS Memory Limit: 64000K
Total Submissions: 7094 Accepted: 1733
Case Time Limit: 2000MS

Description

King George has recently decided that he would like to have a new design for the royal graveyard. The graveyard must consist of several sections, each of which must be a square of graves. All sections must have different number of graves. 

After a consultation with his astrologer, King George decided that the lengths of section sides must be a sequence of successive positive integer numbers. A section with side length s contains s2 graves. George has estimated the total number of graves that will be located on the graveyard and now wants to know all possible graveyard designs satisfying the condition. You were asked to find them.

Input

Input file contains n --- the number of graves to be located in the graveyard (1 <= n <= 1014 ).

Output

On the first line of the output file print k --- the number of possible graveyard designs. Next k lines must contain the descriptions of the graveyards. Each line must start with l --- the number of sections in the corresponding graveyard, followed by l integers --- the lengths of section sides (successive positive integer numbers). Output line's in descending order of l.

Sample Input

2030
           

Sample Output

2
4 21 22 23 24
3 25 26 27
           

Source

Northeastern Europe 2004, Northern Subregion

問題連結:POJ2100 Graveyard Design。

題意簡述:

  對于輸入的n,求一段連續的正整數,使得其平方和等于n。

問題分析:

  本問題采用尺取法解決。

  step1.從1開始,先求出最前面的子序列,使之平方和大于或等于n;

  step2.重複step3和step4,直到整數的平方小于n為止;

  step3.若子序列平方和等于n,則先把解放入向量變量中;去掉子序列的第1個元素,子序列的後面再加上後續整數的平方和;

  step4.将向量中的解取出,輸出結果。

程式說明:

  需要注意資料類型,需要注意起始整數。

AC的C++語言程式如下:

/* POJ2100 Graveyard Design */

#include <iostream>
#include <vector>
#include <stdio.h>

using namespace std;

vector<pair<long long, long long> > ans;

void solve(long long n)
{
    ans.clear();

    long long start = 1, end = 1, sum = 0;
    while (start * start <= n) {
        while (end * end <= n && sum < n) {
            sum += end * end;
            end++;
        }

        if (sum == n)
            ans.push_back(make_pair(start, end));

        sum -= start * start;
        start++;
    }

    int len = ans.size();
    printf("%d\n", len);
    for (int i = 0; i < len; i++) {
        printf("%lld", ans[i].second - ans[i].first);
        for (int j = ans[i].first; j < ans[i].second; j++)
            printf(" %d", j);
        printf("\n");
    }
}

int main()
{
    long long n;

    while(scanf("%lld", &n) != EOF)
        solve(n);

    return 0;
}
           

繼續閱讀