天天看點

【POJ2492】【權重并查集模闆題】

Language: Default A Bug's Life
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 31374 Accepted: 10286

Description

Background 

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 

Problem 

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4      
Sample Output
Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!      

Hint

Huge input,scanf is recommended.

Source

TUD Programming Contest 2005, Darmstadt, Germany

[Submit]   [Go Back]   [Status]   [Discuss]

【POJ2492】【權重并查集模闆題】

Home Page   

【POJ2492】【權重并查集模闆題】

Go Back  

【POJ2492】【權重并查集模闆題】

To top

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int T;
int n,m;
const int maxn = 2010;
int F[maxn];
int d[maxn];

int find(int x)
{
	if(F[x] == -1) return x;
	int t = find(F[x]);
	d[x] ^= d[F[x]];
	return F[x] = t;
}
void merge(int x,int y)
{
	int fx = find(x);
	int fy = find(y);

	F[fx] = fy;
	d[fx] = 1^d[x]^d[y];
}
int Read()
{
	char c; int r; while((c=getchar()) < '0' || c > '9'); r = c-'0';
	while((c=getchar()) >= '0' && c <= '9') r = r* 10 + (c-'0');
	return r;
}
int main()
{
	int C = 1;
    scanf("%d",&T);
	while(T --)
	{
		memset(F,-1,sizeof(F));
		memset(d,0,sizeof(d));
		scanf("%d%d",&n,&m);
		bool found = false;
		for(int i=0;i<m;i++)
		{
			int a,b;
			scanf("%d%d",&a,&b);
			if(found) continue;
			int t1 = find(a);
			int t2 = find(b);
			if(t1 == t2)
			{
				int ret = d[a] ^ d[b];
				if(ret == 0)
				{
					found = true;
				}
			}
			else
			{
				merge(a,b);
			}
		}
		if(found)
		printf("Scenario #%d:\nSuspicious bugs found!\n\n",C++);
		else
		printf("Scenario #%d:\nNo suspicious bugs found!\n\n",C++);

	}
    return 0;
}