天天看點

PAT甲級1108

1108. Finding Average (20)

時間限制

400 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.

Sample Input 1:

7

5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number

ERROR: 9999 is not a legal number

ERROR: 2.3.4 is not a legal number

ERROR: 7.123 is not a legal number

The average of 3 numbers is 1.38

Sample Input 2:

2

aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number

ERROR: -9999 is not a legal number

The average of 0 numbers is Undefined

#include<cstdio>
#include<cstring>
#include<cfloat>
#include<cmath>
int main()
{
  int N;
  scanf("%d", &N);
  double sum = 0.0;
  int count = 0;
  char s[100],s1[100];
  double t;
  for (int i = 0; i < N; i++)
  {
    scanf("%s", s);
    sscanf(s, "%lf", &t);//15位,如果不是數是讀不進去的
    sprintf(s1, "%.2lf", t);//2位
    bool flag = false;
    for (int j = 0; j < strlen(s); j++)
    {
      if (s[j] != s1[j]) { flag = true; break; }
    }//比較字元串
    if (flag || t > 1000 || t < -1000)
    {
      printf("ERROR: %s is not a legal number\n", s);
    }
    else
    {
      sum += t;
      count++;
    }
  }
  if (count)
  {
    if (count == 1)
    {
      printf("The average of 1 number is %.2f\n",sum/count);
    }
    else
      printf("The average of %d numbers is %.2f\n", count,sum / count);
  }
  else
    printf("The average of 0 numbers is Undefined\n");
  return 0;
}      

繼續閱讀