天天看點

HDU4405-Aeroplane chess(機率DP求期望) Aeroplane chess

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1182    Accepted Submission(s): 802

Problem Description Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

Input There are multiple test cases. 

Each test case contains several lines.

The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).

Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  

The input end with N=0, M=0. 

Output For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input

2 0
8 3
2 4
4 5
7 8
0 0
        

Sample Output

1.1667
2.3441
        

  題意:從0點出發,擲篩子,篩子擲到幾(機率相同)就走幾步,其中還有像飛行棋一樣的設定,即可以從某一點直接跳到下一點,而且還可以連續跳躍,問你從0點到n的步數的數學期望。 思路:dp[i] 表示目前走到第i格,距離走到終點的數學期望,遞推即可 前期用dfs重構一下圖就可以了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
using namespace std;
const int maxn = 100000+10;
double dp[maxn];
map<int,int> t;
map<int,int> flight;
int n,m;
void dfs(int sta,int x){
    if(t[x]==0){
        flight[sta] = x;
    }else{
        dfs(sta,t[x]);
    }
}
void init(){
    for(map<int,int>::iterator it = t.begin(); it != t.end(); it++){
        dfs(it->first,it->second);
    }
}
int main(){

    while(cin >> n >> m && n+m){
        t.clear();
        flight.clear();
        while(m--){
            int a,b;
            scanf("%d%d",&a,&b);
            t[a] = b;
        }
        init();
        dp[n] = 0;
        for(int i = n-1; i >= 0; i--){
            dp[i] = 1;
            for(int k = 1; k <= 6; k++){
                if(i+k <= n){
                    if(flight[i+k]==0){
                        dp[i] += dp[i+k]/6;
                    }else{
                        dp[i] += dp[flight[i+k]]/6;
                    }

                }
            }
        }
        printf("%.4lf\n",dp[0]);

    }
    return 0;
}